Pc Lap Counter

Logiciel de comptage
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 Corrupted database - big problem

Go down 
AuthorMessage
scorpio



Number of posts : 8
Registration date : 2017-01-25

PostSubject: Corrupted database - big problem   13/10/2018, 22:33

PCLC ver 5.41d

I've been working away for the past month.
This week I started up the PC for the first time since before I went away.
First thing I did was add a new car, it seemed to add fine on ID 33 but when I went to set up a race the car was not in the list, I then noticed that about half my cars were missing from the drop down list in race setup.

Backing out of the setup page I checked my cars and sure enough out of 32 cars, 12 are missing including the new car on ID 33. I was eventually able to add the car and it also showed up in the race setup dropdown.

Now it gets worse, checking car statistics I'm seinge loads of invalid lap times of 9999.000 on races that have already been run.
Car ID 33 was the latest car to be added and I ran a test race on the car to get some provisional performance timings. At lap 5 the car got black flagged even though there was no infringment so I set up a new race. This race I completed a full twenty laps but when I went to race report at the end all lap timings were in red.
Again back in statistics that new car has a lap time of 9999.000.

As a test I started a new race with a different car I'd added a while ago (ID 24) and ran a race. On race start I got a stop & go even though the car had not moved, I proceeded with the lap & did the stop & go and completed the race. On inspecting race report again everything was in red and a lap time of 9999.000 was recorded into the database.

So now I don't seem to be able to use PCLC, worked fine before I went away, no-one has used the PC as it is dedicated to my track. This PC has 'never' crashed and it's sole purpose is to run PCLC, slot.it Chronos & Bootloader - there is no other SW on it apart from Acrobat reader.

Possibly not relevant - slot.it fw:
SCP-02: 3.00
B1: 2.16

Now I can live with lossing the database, so if you could give me some help at starting this all from scratch that would be great. I seem to remember reading somewhere that it is possible to point PCLC to a different directory so I'm quite happy to give this a go and start a fresh database, it would be a shame to have lost two years of data but as my track has evolved this data is no longer a critical as it used to be. However now my track is permanent I really don't want this to happen again so any help would be appreciated.

Regards

Gary
Back to top Go down
View user profile
guy

avatar

Number of posts : 2119
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Corrupted database - big problem   14/10/2018, 19:08

Lap time of 9999.000 is very strange and at this moment i really don't see how it could happen, may be something related to the firmware of your oXigen components.

Here is the procedure to completely reinstall Pc Lap Counter:
- Uninstall Pc Lap Counter via the control panel of windows
- Remove the Folder c:\Pc Lap Counter
- Install again Pc Lap Counter

If you use the latest oXigen firmware i suggest you to install  Pc lap Counter version 5.42.

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
scorpio



Number of posts : 8
Registration date : 2017-01-25

PostSubject: Re: Corrupted database - big problem   15/10/2018, 00:04

Hi Guy,

I was able to get my car list back by editing car.ini.
I was also able to create a database from scratch by copying pclc_505_empty.mdb to a location in my documents folder and renaming it to pclc_505.mdb.
By editing racectrl.ini and adding the following:
[Database]
DefaultDir=C:\Users\gary\Documents\PCLapCounter\RaceDb

I was able to start PCLC with a fresh new database and all my cars - great I thought.
On running a race I'm still getting red items in the race report 'Race Details by Lap' and lap times are still being shown in Car Statistics as 9999.000.

So next step - as per your instructions I uninstalled PCLC & deleted the folder (keeping a backup of the appropriate ini files.)
I then installed v5.42 and ran a race and still get the red lap results & Lap times are still being shown as 9999.000.
Also all lap times are recorded - if I run a race I get current & previous times shown on the Display and race reports also show the times (in red) but it is the storing into the database statistics that is weird with this 9999.000.
I also don't understand why the reports are in red as previously these would be green if better than previous lap & red if worse.

So now I just tried updating to the latest 3.10 O2 FW out of curiousity and still same thing.

So where to from here as I cannot use the SW now and I don't know why?

Slot.it Chronos seems to work OK but there is no database so thats kinda moot.

Thanks

gary
Back to top Go down
View user profile
guy

avatar

Number of posts : 2119
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Corrupted database - big problem   15/10/2018, 00:42

Maybe there is something with the decimal separator in the regional settings of your computer, could you send me your database by email at info@pclapcounter.be so i can check.


_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
Sponsored content




PostSubject: Re: Corrupted database - big problem   

Back to top Go down
 
Corrupted database - big problem
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Pc Lap Counter :: General-
Jump to: