Pc Lap Counter

Logiciel de comptage
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 PCL missing lap counts during lane change [Solved]

View previous topic View next topic Go down 
Go to page : 1, 2  Next
AuthorMessage
lars_jacobsen



Number of posts : 92
Registration date : 2006-10-02

PostSubject: PCL missing lap counts during lane change [Solved]   25/11/2008, 15:07

Hi Guy

The last couple of races we have discovered that PCL misses laps when we are changing lanes.

It has to do with the detector that has to keep checking for passing cars after time has run out in a segment - yesterday 4 drivers missed a lap because they passed the sensors right after the time ran out.

I would expect that others have expierenced the same problem, and is curious to hear what we can do to prevent this in the future?

Hope you are able to solve this
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   25/11/2008, 16:45

Hi,

By default when power go OFF PCLC wait 1 second before he stop detection, think you should extend it to 2 seconds :


_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel


Last edited by guy on 1/2/2009, 01:08; edited 1 time in total
Back to top Go down
View user profile http://www.pclapcounter.be
lars_jacobsen



Number of posts : 92
Registration date : 2006-10-02

PostSubject: Re: PCL missing lap counts during lane change [Solved]   25/11/2008, 17:13

great idea - will try that

:-)

Think actually the timer is set to 6 secs, but could be mistaken
Back to top Go down
View user profile
lars_jacobsen



Number of posts : 92
Registration date : 2006-10-02

PostSubject: Re: PCL missing lap counts during lane change [Solved]   9/1/2009, 11:26

I have checked our settings for delay and it was indeed set to 6 seconds

We have noticed that the error often appears when a car passes the line exactly when time runs out - in this situation the lap is not counted regardles of the setting i delay

We are using the Phidget USB cards, and I was wondering if this could have something to do with this?

Looking forward to hearing from you soonest

B/Rgds
Lars
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   9/1/2009, 13:18

all rejected laps are displayed in the message part of PCLC , did you see something in the message part Question

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
lars_jacobsen



Number of posts : 92
Registration date : 2006-10-02

PostSubject: Re: PCL missing lap counts during lane change [Solved]   9/1/2009, 23:50

the problem is that the lap is not rejected, it is simply not detected Crying or Very sad
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   10/1/2009, 00:01

So there is not messages cheers
Did you use the Phidget interface also for power control ?
I answer that because when the time runs out PCLC activate the digital outputs to cut the power and maybe when a car cross the line in the sametime then the Phidget not send the information, normaly i will have my Phidget interface back next week...i will test it.

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
lars_jacobsen



Number of posts : 92
Registration date : 2006-10-02

PostSubject: Re: PCL missing lap counts during lane change [Solved]   10/1/2009, 19:17

hi guy

We use both the relay card and a phidget card for the detection - actually this is exactly what we have been considering that the phidget cuts something when it happens at the same time

On a normal race night this happens maybe once or twice a month, but still a big problem when running important races and people have do discuss whether they got cheatet of a lap or not

Hope you are able to make some changes

:-)
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   14/1/2009, 20:19

Hi Lars,

Just a question, which version of PCLC you use ?

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
lars_jacobsen



Number of posts : 92
Registration date : 2006-10-02

PostSubject: Re: PCL missing lap counts during lane change [Solved]   15/1/2009, 23:17

Hi Guy

The latest version
Back to top Go down
View user profile
lars_jacobsen



Number of posts : 92
Registration date : 2006-10-02

PostSubject: Re: PCL missing lap counts during lane change [Solved]   21/1/2009, 23:43

hi again guy

Just wanted to hear if you found anything in the Phidget matter with regards to the missing lap counts?

Looking forward to hearing from you

K/Rgds
Lars
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   22/1/2009, 00:07

I received my phidget back but i did not yet make the test, i promise you that i will do it this weekend with my 0-0-4 and 0-16-16.

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
lars_jacobsen



Number of posts : 92
Registration date : 2006-10-02

PostSubject: Re: PCL missing lap counts during lane change [Solved]   23/1/2009, 02:54

looking forward to your observations :-)

We are using the exact same phidget cards as you so should be comparable
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   23/1/2009, 23:02

I make the test with my 0/16/16 and 0/0/4 and it's working fine , just after the end of a segment PCLC still detect cars during the time specified in the options "When power go OFF wait x sec before stop detection".

During my test i have see a minor bug but it does not generate missing laps: when a car cross the S/F line just after the end of a segment then the delay before PCLC really stop detection is updated and it should not...for exemple if the segment end at 12:00:00
and delay before PCLC really stop detection is 6 sec and a car cross the s/f line at 12:00:01 then PCLC will really stop detection at 12:00:07 and not at 12:00:06.
This little bug will be fixed in version 4.53.

So, i think your phidget interface / detector not send the lap detection information during the lane change period but why only during that period...i don't know scratch

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
lars_jacobsen



Number of posts : 92
Registration date : 2006-10-02

PostSubject: Re: PCL missing lap counts during lane change [Solved]   30/1/2009, 02:03

hi again guy

As follow up to your test the exact same thing happened on monday, where we had race night - one of the cars crossed the finish line exactly when the heat ended and his lap was not counted.

We have checked that the sensors are triggered which they are - no matter what, and also the phidget gives signal to the pc, so must be something else.

Please check your own setup and make the test where a car crosses at exactly the time of heat completion, think you will get the same bug

:-)

Hope you are able to do something about this, as it can be frustrating when we are running championships (people don't like missed lap counts)

Awaiting your investigation once again

Very Happy
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   1/2/2009, 01:06

Hi Lars,

Even i cross the finish line exactly when the heat ended i don't have missing laps scratch

Is there other members here who have the same problem ?

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
Snekke



Number of posts : 14
Localisation : Denmark
Registration date : 2008-06-29

PostSubject: Re: PCL missing lap counts during lane change [Solved]   1/2/2009, 19:36

Yes we have the exact same problem with the phidgets 8/8/8, (we also use it for power control) and we have tried everything with the sensors and the electronics. The sensors are trigged and the phidget react on the signal from the electronics (digital - 500ms). Sad

Because of this we decided not to use PC lab counter for our track but if you have a solution for this problem we will make a reconsideration.
We need a 100 % reliable software with no missing lap counts no matter what.
At the moment we use Trackmate software and interface with the same sensors and electronic, without any missing laps.
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   1/2/2009, 19:57

Hi Snekke, Pc Lap Counter is also compatible with the trackmate interface, maybe you can test it and so we will know if the problem happend only with phidget interface or maybe you already done that test Question

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
Snekke



Number of posts : 14
Localisation : Denmark
Registration date : 2008-06-29

PostSubject: Re: PCL missing lap counts during lane change [Solved]   1/2/2009, 20:41

Sorry I forgot to mention that I already have tried the Trackmate interface on PCLC and it seems to work perfect
( I just test it in one race) Embarassed
I can make a longer test on Wednesday if you like
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   1/2/2009, 20:59

Snekke wrote:
I can make a longer test on Wednesday if you like

Yes that would be GREAT , thank you Very Happy

PS:
As you know heat editor of PCLC have be improved....

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
slotmanege



Number of posts : 54
Localisation : Netherlands
Registration date : 2007-11-02

PostSubject: Re: PCL missing lap counts during lane change [Solved]   2/2/2009, 09:57

guy wrote:
...
Is there other members here who have the same problem ?

Hi,

We also have the same problem, using Phidget 8/8/8.

Regards,
Danny
http://www.slotmanege.nl
Back to top Go down
View user profile http://www.slotmanege.nl
Foiler



Number of posts : 33
Localisation : Michigan - USA
Registration date : 2007-02-16

PostSubject: Missing Laps   2/2/2009, 18:59

Guy & Fellow Racers,
I use a Phidget 0/16/16, and our club racing is always done with Laps-limited races.
(We like to hear the "Last-lap" .wav file which can only be heard in Laps-limited races.)
Therefore, the clock timing is not critical at the end of any race.

For testing purposes, we will try some Time-based races and trigger the sensors just as time expires in a race segment.
We will report back our findings.

Foiler in Michigan-USA
Back to top Go down
View user profile
Snekke



Number of posts : 14
Localisation : Denmark
Registration date : 2008-06-29

PostSubject: Re: PCL missing lap counts during lane change [Solved]   5/2/2009, 22:58

As I promise, I test the Trackmate interface on PCLC with a lot of “changing lanes” .
The Phidget interface was totally disconnected.
We did not discover any missing lap counts.
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   6/2/2009, 02:00

Hi Snekke, thank you for the test Very Happy
It's like missing laps during lane change occur only with phidget interface, hope to have some return from Foiler soon Wink

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
Foiler



Number of posts : 33
Localisation : Michigan - USA
Registration date : 2007-02-16

PostSubject: No Missing Laps Here   6/2/2009, 05:40

Guy & Fellow PCL Users,
I ran several time-based races tonight with my Phidget 0/16/16 & PCL v4.53.
I really tried to "fool" the Phidget and PCL by crossing the finish line the instant the race segment time expired, yet I experienced NO missed laps. Cool

I ran races that required drivers to finish their lap after time expired, and ran races that did not require drivers to finish their lap after time expired. I tripped the sensors the instant before, during, and after the segment time expired. Still, no laps were missed in all of my testing.

I even simulated all four cars crossing the finish line the instant time expired without any missed laps.

For reference, my PC is just an AMD 1 Ghz processor, with 512 Mb RAM and Windows XP Pro with SP3. My Phidget 0/16/16 board is running through a USB 2.0 port, but I really don't think the USB 2.0 is a factor. I have four infrared sensors wired exactly per Diagram 2 in the following schematic:

http://pclapcounter.winnerbb.net/phidgets-interface-kit-f14/schema-to-connect-detector-to-phidget-0-16-16-t265.htm

So, I wish I could explain why some of you are experiencing missed laps with your Phidget boards. I cannot. Question

Foiler in Michigan - USA
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: PCL missing lap counts during lane change [Solved]   

Back to top Go down
 
PCL missing lap counts during lane change [Solved]
View previous topic View next topic Back to top 
Page 1 of 2Go to page : 1, 2  Next
 Similar topics
-
» OH NO... Got my oil change.......SOLVED
» Engine is missing / hesitating under load. Noticeable in 1,2,3 gears. Any ideas?
» Distributor Cap Removal - What am I missing???
» Poor gasoline causes missing??
» Change shaft - Advice pls

Permissions in this forum:You cannot reply to topics in this forum
Pc Lap Counter :: Hardware :: Phidgets interface kit-
Jump to: