Pc Lap Counter

Logiciel de comptage
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 PCL missing lap counts during lane change [Solved]

View previous topic View next topic Go down 
Go to page : Previous  1, 2
AuthorMessage
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   7/2/2009, 01:25

Thank Foiler for the test, just a question: i assume that you use the same phidget 0/16/16 for the power control and not another phidget interface for power control (like a 0/0/4 ) ?

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
Foiler



Number of posts : 33
Localisation : Michigan - USA
Registration date : 2007-02-16

PostSubject: No Missing Laps Here   7/2/2009, 18:32

Guy,
That is correct.
I use my Phidget 0/16/16 card for both lap counting and triggering external relays for track power.

Foiler in Michigan-USA
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   8/2/2009, 17:13

It's like the problem of missing laps during lane change occur with:
- Phidget interface 8/8/8 (Snekke and Slotmanege)
- Phidget interface 0/16/16 + 0/0/4 for power control (Lars)

No problem with:
- Trackmate interface (Snekke)
- Phidget interface 0/16/16 without a 0/0/4 for powercontrol, powercontrol made by the same 0/16/16 (Foiler)

You have to know that all interfaces (Phidget, Trackmate, DS Racing...) trigger the same event in PCLC.
Also for PCLC there is no difference between a Phidget interface 8/8/8 and a 0/16/16 , PCLC use the Phidget Library which is independant of the type of the phidget interface.
Knowing that, i think i could say that problem of missing laps during lane change is not linked to Pc Lap Counter.

Idea I think that when PCLC send the command to the Phidget interface to cut the power then the Phidget refresh rate is disturbed and so systems which send small pulse could have missing laps during that period.

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
slotmanege



Number of posts : 54
Localisation : Netherlands
Registration date : 2007-11-02

PostSubject: Re: PCL missing lap counts during lane change [Solved]   9/2/2009, 13:14

Thanks for the investigation Guy (and all others for the input).
I do not know how the software of PCLC is designed... is it a singlethreaded or multithreaded application? Does it react on events or is it interrupt based?
But I could imagine that whenever PCLC is busy handling one event, all other events that are received during that timeperiod are not handled anymore?
But then again... sure... it could also be hardware related (Phidget hardware issue).
Back to top Go down
View user profile http://www.slotmanege.nl
Snekke



Number of posts : 14
Localisation : Denmark
Registration date : 2008-06-29

PostSubject: Re: PCL missing lap counts during lane change [Solved]   9/2/2009, 22:15

Quote :
I think that when PCLC send the command to the Phidget interface to cut the power then the Phidget refresh rate is disturbed and so systems which send small pulse could have missing laps during that period.

Hi Guy
I have a pulse-width on 500ms. This is not a “small pulse”
Do you know what the Phidget require in pulse-width on the digital input ?
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   9/2/2009, 22:33

slotmanege wrote:

But I could imagine that whenever PCLC is busy handling one event, all other events that are received during that timeperiod are not handled anymore?
Events are queued by Windows, so even PCLC is busy he will receive it

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   9/2/2009, 22:38

Snekke wrote:
Quote :
I think that when PCLC send the command to the Phidget interface to cut the power then the Phidget refresh rate is disturbed and so systems which send small pulse could have missing laps during that period.

Hi Guy
I have a pulse-width on 500ms. This is not a “small pulse”
Do you know what the Phidget require in pulse-width on the digital input ?
Regarding the refresh rate of the Phidget i suppose that the pulse-width should be > 0.008 sec, so your pulse-width is good.

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
Snekke



Number of posts : 14
Localisation : Denmark
Registration date : 2008-06-29

PostSubject: Re: PCL missing lap counts during lane change [Solved]   9/2/2009, 23:10

Guy wrote:
Events are queued by Windows, so even PCLC is busy he will receive it
Guy wrote:
Regarding the refresh rate of the Phidget i suppose that the pulse-width should be > 0.008 sec, so your pulse-width is good.


This means that I can’t do anything to avoid missing labs when I use the Phidget interface?
I have the Trackmate interface but how about the other fellows ?
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   10/2/2009, 00:45

What i don't understand is why Foiler don't have the problem ?
I will integrate the last update of the Phidget Library in PCLC...maybe it will solve the problem for people who use a 8/8/8 or a 0/16/16 + 0/0/4
Unfortunately i can't do it immediately because i have to finish other project.

PS:
Will be fine to have some return from Main Line Hobbies...they use Phidghet 0/16/16 and also 0/0/4 for power control

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   10/2/2009, 22:28

I had some return for Main Line Hobbies and they don't have the problem of missing lap during lane change.
They use PCLC v4.52 and a phidget 0/16/16 + 0/0/4 for powercontrol, same configuration as Lars scratch

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
lars_jacobsen



Number of posts : 92
Registration date : 2006-10-02

PostSubject: Re: PCL missing lap counts during lane change [Solved]   11/2/2009, 16:15

Hi again again Guy

We are still struggeling with missed laps, and we don't seem to find any solution for it on our hardware.

have 2 thing that maybe could have something to do with this:

1. could it be caused if the USB hardware has issues? - not that this seems to be the case with our pc, but just a thought

2. perhaps the missed laps is caused by the settings for "minimum lap time" - we always run time based races when you do not cross the finish line at the end - I am just wondering how pcl defines the lap times, if e.g. the driver finishes heat 1 and ends up just 10 cm from the starting line - this would make his first lap extremely fast..

I don't know if above has any effect on the problems that we are struggeling with, but we are still missing lap counts

Crying or Very sad
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   13/2/2009, 01:48

lars_jacobsen wrote:
Hi again again Guy

2. perhaps the missed laps is caused by the settings for "minimum lap time" - we always run time based races when you do not cross the finish line at the end - I am just wondering how pcl defines the lap times, if e.g. the driver finishes heat 1 and ends up just 10 cm from the starting line - this would make his first lap extremely fast..
If it was caused by the "minimum lap time" you should see messages and i remember that you have say that you didn't saw messages.

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   14/2/2009, 02:05

Lars, did you set Pc Lap Counter to play sound ?
If yes...i suggest you try without sound Idea (in the general options untick "sound enable")

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
Snekke



Number of posts : 14
Localisation : Denmark
Registration date : 2008-06-29

PostSubject: Re: PCL missing lap counts during lane change [Solved]   8/3/2009, 22:38

I make a lot of test today with Phidget interface and no sound at the end of a segment or end of race ( only the start wav was active )

And guess what : No missing laps cheers

It would be great if Lars did the same test
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   12/3/2009, 00:13

No news of Lars Suspect

Snekke, thank you for the test....so it's linked to the way PCLC play the sound at segment end.
Just for my information, which version did you use during your test , version 4.52,4.53 or 4.54 ?

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
Snekke



Number of posts : 14
Localisation : Denmark
Registration date : 2008-06-29

PostSubject: Re: PCL missing lap counts during lane change [Solved]   12/3/2009, 00:44

I test it with version 4.53 and 4.54
Back to top Go down
View user profile
guy

avatar

Number of posts : 2046
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: PCL missing lap counts during lane change [Solved]   18/4/2009, 23:11

Since version 4.55 i changed the way PCLC play the sound at segment end, think it should solve the problem of missing lap during lane change.

_________________
www.pclapcounter.be
www.pclapcounter.com
pclapcounter video channel
Back to top Go down
View user profile http://www.pclapcounter.be
Sponsored content




PostSubject: Re: PCL missing lap counts during lane change [Solved]   

Back to top Go down
 
PCL missing lap counts during lane change [Solved]
View previous topic View next topic Back to top 
Page 2 of 2Go to page : Previous  1, 2
 Similar topics
-
» OH NO... Got my oil change.......SOLVED
» Engine is missing / hesitating under load. Noticeable in 1,2,3 gears. Any ideas?
» Distributor Cap Removal - What am I missing???
» Poor gasoline causes missing??
» Change shaft - Advice pls

Permissions in this forum:You cannot reply to topics in this forum
Pc Lap Counter :: Hardware :: Phidgets interface kit-
Jump to: