Pc Lap Counter

Logiciel de comptage
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 Fuel Management Settings

View previous topic View next topic Go down 
AuthorMessage
mainlinehobbies

avatar

Number of posts : 129
Localisation : USA
Registration date : 2006-08-02

PostSubject: Fuel Management Settings   13/12/2009, 19:43

We just begin using fuel management during our races, and the guys love it!

Here's our typical race settings:
3 minute heats, all drivers race on all lanes, automatic lane rotation, and a 1.30 inner segment time (Allows the guys to move their cars and get back and ready) NO auto restart after the inner segment.

Now we add fuel management: Generate Pit In after 2 seconds under light bridge (Phidget 0/16/16), Lane power is not turned off during fuel to allow for splash and go's

Here's the error were seeing. If someone is fueling when the segment ends, the fueling stops when the light goes red (That is correct), the lanes are rotated, but then some lanes are turned BACK ON! At first I thought this was the software being smart, allowing the car in the pits to get out of the pits and then shut the lane back off, but it turns the lane on where the driver is rotating TO, not wherer they are. We are using Phidgets 0/0/4's on this track (NINCO TRACK), and after this happens, lane power is very flaky for the rest of the race, sometimes not turning off a lane at the end of the segment, and so on, even though the screen shows all lanes are unchecked (Off). Pressing "Power On" and then "Power Off" does not correct the error. the only way to fix it is to unplug the Phidget boards and plug them back in, then hit power on, power off.

We are running 5.01, and we see something along the lines of this error with our other track, running 4.58 with an LPT1 card in place of two Phidget 0/0/4's.
Back to top Go down
View user profile http://www.mainlinehobbies.com
guy

avatar

Number of posts : 2049
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Fuel Management Settings   14/12/2009, 20:53

mainlinehobbies wrote:
If someone is fueling when the segment ends, the fueling stops when the light goes red (That is correct), the lanes are rotated, but then some lanes are turned BACK ON!
At first I thought this was the software being smart, allowing the car in the pits to get out of the pits and then shut the lane back off, but it turns the lane on where the driver is rotating TO, not wherer they are.
That's a bug and will be fixed in version 5.02, in fact the power go ON for the lane who was fueling when the segment ends and this happend just after the lanes rotation.

mainlinehobbies wrote:

and after this happens, lane power is very flaky for the rest of the race, sometimes not turning off a lane at the end of the segment, and so on, even though the screen shows all lanes are unchecked (Off). Pressing "Power On" and then "Power Off" does not correct the error. the only way to fix it is to unplug the Phidget boards and plug them back in, then hit power on, power off.

We are running 5.01, and we see something along the lines of this error with our other track, running 4.58 with an LPT1 card in place of two Phidget 0/0/4's.
I think that for some unknow reason the PC lost the connection with the Phidget interface, you should hear the unplug sound and a message should be displayed in PCLC, did you see that kind of message ?
Back to top Go down
View user profile http://www.pclapcounter.be
mainlinehobbies

avatar

Number of posts : 129
Localisation : USA
Registration date : 2006-08-02

PostSubject: Re: Fuel Management Settings   14/12/2009, 21:41

Nope, no Hardware disconnect sound when this all happened.
Back to top Go down
View user profile http://www.mainlinehobbies.com
guy

avatar

Number of posts : 2049
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Fuel Management Settings   15/12/2009, 00:39

I fix the bug as i mentioned and publish the beta of PCLC 5.02 here
Now about the second point (lane power was very flaky for the rest of the race) , it's not linked to the bug.
Regarding your explanation it happend only with fuel managment but Foiler also use the fuel managment with a Phidget 0/16/16 and actually he did not report me such problem.
When it happend again i suggest you take a look at the message box of PCLC and check if there are some messages which can help us to find the reason of the lane power flaky.


Last edited by guy on 13/1/2010, 17:45; edited 1 time in total
Back to top Go down
View user profile http://www.pclapcounter.be
mainlinehobbies

avatar

Number of posts : 129
Localisation : USA
Registration date : 2006-08-02

PostSubject: Re: Fuel Management Settings   15/12/2009, 02:18

Thanks, I'll keep an eye on it
Back to top Go down
View user profile http://www.mainlinehobbies.com
mainlinehobbies

avatar

Number of posts : 129
Localisation : USA
Registration date : 2006-08-02

PostSubject: Re: Fuel Management Settings   27/6/2010, 21:29

Happened again yesterday... no messages.

Event timeline:
Driver in Lane 5 (Purple) was fueling when segment click hit 0
PCLC rotates lane 5 (Purple) into Lane 6 (green)
Tick mark on lane power shows that power is off to all lanes except lane 6
Power is still on to lane 5 driver, even after pulling away from the light bridge, even though PCLC shows lane 5 power off, lane 6 power on
Situation was corrected by pressing "Power ON" and then "Power Off"



Any way to correct this from happening, meaning keeping all lanes off after segment no matter if the driver is under the light bridge or not?
Back to top Go down
View user profile http://www.mainlinehobbies.com
guy

avatar

Number of posts : 2049
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Fuel Management Settings   28/6/2010, 00:05

you will be so kind to specify which version of Pc Lap Counter you use Question Question
Back to top Go down
View user profile http://www.pclapcounter.be
mainlinehobbies

avatar

Number of posts : 129
Localisation : USA
Registration date : 2006-08-02

PostSubject: Re: Fuel Management Settings   28/6/2010, 06:48

Sorry! PCLC5.05d (Current release)
Back to top Go down
View user profile http://www.mainlinehobbies.com
guy

avatar

Number of posts : 2049
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Fuel Management Settings   28/6/2010, 11:41

Thank, i test it with my Phidget 0/16/16 and i don't have any problem : at the end of a segment Pc Lap Counter power OFF all lanes and this even a car stay on the sensor.
Think i miss something, could you send me the corresponding racectrl.ini file so i can test it with the same options.
Back to top Go down
View user profile http://www.pclapcounter.be
guy

avatar

Number of posts : 2049
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Fuel Management Settings   17/7/2010, 16:49

I test with your file and i don't have any problems, i test it with a Phidget 0/0/16 for the car detection and relay connected to the parallel port for the power control and starting lights....it's work fine scratch
Next time you have the problem it will be fine that you take a copy of the file error.log and send it to me (error.log is in the Pc Lap Counter folder).
Back to top Go down
View user profile http://www.pclapcounter.be
Sponsored content




PostSubject: Re: Fuel Management Settings   

Back to top Go down
 
Fuel Management Settings
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» What fuel management programmer is the best bang / buck?
» FMF fuel programmer settings
» k100 85 stall on the road
» New WRR Owner, question about Fuel Management
» Can I run exhaust without fuel/engine management?

Permissions in this forum:You cannot reply to topics in this forum
Pc Lap Counter :: Race Setting - Config courses-
Jump to: