Pc Lap Counter

Logiciel de comptage
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 Problem with laps & false start setection [BUG FIXED]

View previous topic View next topic Go down 
AuthorMessage
ferrari

avatar

Number of posts : 78
Localisation : Sydney Australia
Registration date : 2006-01-25

PostSubject: Problem with laps & false start setection [BUG FIXED]   5/8/2006, 09:58

At the beginning of the race we start before the detectors. If you jump the start and cross detection (false start detection is on) you get a penalty…Zoom screen shows –1 laps and main screen shows empty value…when you cross detection you get 0 laps…very good and OK.

However this only happens in the first segment. All other segments (auto rotation) start the race with a 0 laps and when you cross detection you immediately get 1 lap. False start detection no longer works as power is only made available at GO.

Question
Back to top Go down
View user profile
guy

avatar

Number of posts : 2058
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   19/8/2006, 19:21

you right , false start detection work only at the first segment, i will fix that bug

cheers
Back to top Go down
View user profile http://www.pclapcounter.be
ferrari

avatar

Number of posts : 78
Localisation : Sydney Australia
Registration date : 2006-01-25

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   20/8/2006, 01:34

Also the lap counting.
In first segment you get 0 laps when cross detection at the start Very Happy
In other segments you get 1 lap when cross detection at the start Sad
Back to top Go down
View user profile
guy

avatar

Number of posts : 2058
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   20/8/2006, 02:10

ferrari wrote:
Also the lap counting.
In first segment you get 0 laps when cross detection at the start Very Happy
In other segments you get 1 lap when cross detection at the start Sad
Yes i will fix it also, in fact it happend only when you specify in the option screen that the race start before the detector and there is a work around:

the lap counting problem occur after the first segment for drivers who just begin the race (they don't make any lap in first segment).
While waiting for the correction it is necessary to put these drivers AFTER the detector

cheers
Back to top Go down
View user profile http://www.pclapcounter.be
guy

avatar

Number of posts : 2058
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   2/9/2006, 21:07

Bug fixed in Pc lap Counter 4.33c, more information here http://pclapcounter.winnerbb.net/viewtopic.forum?t=90
Back to top Go down
View user profile http://www.pclapcounter.be
mainlinehobbies

avatar

Number of posts : 129
Localisation : USA
Registration date : 2006-08-02

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   8/9/2006, 20:55

We have a slightly different problem. With false start detection enabled (We have it set for 3 seconds), the 3 second count starts from the moment of the false start, not from the moment of the start of the race, so some drivers are not being penalised at all. Also, the penality is not always 3 seconds, most of the time it is, sometimes it can be up to 20 seconds. Are we missing something?
Back to top Go down
View user profile http://www.mainlinehobbies.com
guy

avatar

Number of posts : 2058
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   8/9/2006, 22:01

mainlinehobbies wrote:
We have a slightly different problem. With false start detection enabled (We have it set for 3 seconds), the 3 second count starts from the moment of the false start, not from the moment of the start of the race, so some drivers are not being penalised at all. Also, the penality is not always 3 seconds, most of the time it is, sometimes it can be up to 20 seconds. Are we missing something?
Imaging you want a start countdown of 5 second and a false start penalty of 10 seconds , you have to set:




Please try it with this configuration and tell me if it work, false start detection is enabled as soon as the 'start' countdown begin.

cheers
Back to top Go down
View user profile http://www.pclapcounter.be
mainlinehobbies

avatar

Number of posts : 129
Localisation : USA
Registration date : 2006-08-02

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   8/9/2006, 23:14

The problem is that if someone false starts right as the power is turned onto the track, they are currently held for 4 seconds. Our countdown is currently set for 3 seconds, but you have to add in the random time it takes after the countdown untill the lights turn green. By the time the lights turn green, the penality is already over. If we make it 10 seconds, then the driver looses a lap and a half (We have a very fast track, lap times average 5-6 seconds). Is there any way to get the penalty to start counting down after the light goes green? that way it is always an identical amount of time for the penalty.
Back to top Go down
View user profile http://www.mainlinehobbies.com
guy

avatar

Number of posts : 2058
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   9/9/2006, 13:13

mainlinehobbies wrote:
The problem is that if someone false starts right as the power is turned onto the track, they are currently held for 4 seconds. Our countdown is currently set for 3 seconds, but you have to add in the random time it takes after the countdown untill the lights turn green. By the time the lights turn green, the penality is already over. If we make it 10 seconds, then the driver looses a lap and a half (We have a very fast track, lap times average 5-6 seconds). Is there any way to get the penalty to start counting down after the light goes green? that way it is always an identical amount of time for the penalty.
Ok now i understand your problem, i will modify the false start penalty to take care of the duration of the start countdown.
cheers
Back to top Go down
View user profile http://www.pclapcounter.be
guy

avatar

Number of posts : 2058
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   16/9/2006, 21:19

Done in version 4.34
Back to top Go down
View user profile http://www.pclapcounter.be
ferrari

avatar

Number of posts : 78
Localisation : Sydney Australia
Registration date : 2006-01-25

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   14/10/2006, 13:30

Problem is back.

Cars are given 1 lap at start of the race immediately when crossing detector. This happens after the first segment.

Cars are also given 1 lap when crossing detectors before given a false start penalty. This happens after the first segment.

Using 4.35 Beta
Back to top Go down
View user profile
guy

avatar

Number of posts : 2058
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   14/10/2006, 15:19

ferrari wrote:
Problem is back.

Cars are given 1 lap at start of the race immediately when crossing detector. This happens after the first segment.

Cars are also given 1 lap when crossing detectors before given a false start penalty. This happens after the first segment.

Using 4.35 Beta
Don't have the problem when i don't use heat editor, but if i use the the heat editor i have the the problem.
In your case this you setup your race with heat editor ?
Back to top Go down
View user profile http://www.pclapcounter.be
ferrari

avatar

Number of posts : 78
Localisation : Sydney Australia
Registration date : 2006-01-25

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   15/10/2006, 02:38

Quote :
In your case this you setup your race with heat editor ?

No.

We manually set rotation in race setup and use Auto rotation function.

cheers
Back to top Go down
View user profile
guy

avatar

Number of posts : 2058
Localisation : Belgique
Registration date : 2006-01-25

PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   16/10/2006, 22:28

Should be definitively fix in 4.35 beta 2 (even with heat editor): http://pclapcounter.winnerbb.net/viewtopic.forum?t=135
Back to top Go down
View user profile http://www.pclapcounter.be
slotsnake



Number of posts : 2
Registration date : 2006-10-15

PostSubject: inf   31/10/2006, 18:42

ciao Pino

vorrei sapere le modifiche della nuova versione quali sono
e se sono utili


saluti
max
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Problem with laps & false start setection [BUG FIXED]   

Back to top Go down
 
Problem with laps & false start setection [BUG FIXED]
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» False start rule causes problems when applied sporadically
» 2 Contrasting Views on the False Start Rule
» Did Yohan Blake cause Bolt's false start?
» False start rule makes athletes edgy for USA Champs
» Hijet failed MOT on emissions.

Permissions in this forum:You cannot reply to topics in this forum
Pc Lap Counter :: List of fixed bugs-
Jump to: